befs_anneの日記

雰囲気でネットワークをやっている

「WSLのVagrantからWindowsのVagrantが見えない」的なエラーの解消

概要

タイトルの通り。最初は「WSLとWindowsVagrantのバージョンが違う」というエラーが出ていて、Windows側をWSLと同じバージョンまで上げたらWindows側のVagrantのバージョンがUnknownになった。エラーメッセージに従って環境変数をいじるなどしたが効果なし。

解消方法

(bashではなく)コマンドプロンプトで以下を実行したら解決したっぽい。

vagrant plugin repair

実際に出力されたメッセージとかもメモしておきたかったけど、コマンドプロンプトはログが残せないのが不便……。